Living in a 2.0 world: Versioning our Standards

We are beginning to approach a phase where we need to support a 2nd generation of standards while the first generation still exists (e.g. VOTable, 2nd generation DAL, v1.1 of VOResource extensions). We recognize that we cannot "upgrade" the entire IVOA simultaneously, so we must live with both generations existing in the system simultaneously. Are our applications prepared for this? How should applications react when a version of a service or document is not supported? Are their any issues that will complicate life for users?

Comment by ChristopheArviset
This Topic has not been co-sponsored, so it will not go to the 2008 Assessment and Roadmap document.


Topic revision: r2 - 2008-06-23 - ChristopheArviset
 
This site is powered by the TWiki collaboration platformCopyright © 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback