VOSpace-1.0 WSDL and schema
This is a discussion page for the WSDL and schema for the VOSpace-1.0 service.
This is somewhere where we can post proposals for schema and WSDL to enable interested parties to discuss the different versions.
For each version there is a Change request section - please add to this and vote on other suggestions
- +1 if you agree
- -1 if you disagree
- 0 if you have no particular preference
Once we have finalised the WSDL and schema, the final versions will be posted on the main Grid & Web Services
page.
News
- Schema discussion page created.
Core schema
This is the main section for schema and WSDL files.
The files for the 1.0 VOSpace release are
-
VOSpace-v1.0.wsdl
the main WSDL file.
-
VOSpaceBase-v1.0.xsd
a subsidiary schema file that contains core types that might be useful in implementing a VOSpace server cf. the WSDL which contains types that are used only in the web service interface.
These file are packaged in a zip file which is named with the release candidate number for each sucessive release candidate. The exact release candidate number is also reflected in the files in
- the version attribute of the top level xsd:schema element in the schema file
- the name attribute of the top level wsdl:definitions element in the WSDL file
Version 1.0rc1
This is the first 'official' release candidate of the VOSpace interface definition, and is based on version 0.21 of the specification document, though is known not to follow this document exactly, as there are areas still to be finalized for which the WSDL is the best 'source'.
Change Requests
Rename bulk data transfer operations
- I stilll find the data transfer operations confusing- I think that the basic problem is that the push and pull verbs are opposite in meaning and viewed from opposite perspectives. I have a new set of proposals
old name |
new name" |
pushDataToVoSpace |
importDataClientPush |
pullDataToVoSpace |
importDataServerPull |
pushDataFromVoSpace |
exportDataServerPush |
pullDataFromVoSpace |
exportDataClientPull |
which I think are better because
- the overall objective of the operation is the first verb
- the active party in the transfer is identified
- the direction of the transfer is then related to the active party.
--
PaulHarrison - 13 Jun 2006
Votes
Use namespaces in release candidates that include release number
Votes
Make sure that the naming of operations/parameters more closely matches the written specification
Votes
Remove enumerations for security related types
Votes
Remove enumerations of transport keys
Votes
Remove enumerations of parameter key values
Votes
Remove any idea of callbacks
Votes
Remove the use of ChangeOwner operation